Support

System requirements

Current version of the virtual labs requires Adobe Flash plug-in to be enabled in your web browser. We strongly recommend that you use Google Chrome for best performance and experience. Allow running Adobe Flash when prompted, you might need to reload the page.

get.adobe.com/flashplayer

Contact support